Message: Weird bug - energy deposit from transportation plus OutOfWorld when really well inside it. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Weird bug - energy deposit from transportation plus OutOfWorld when really well inside it. 

Keywords: Bug, transportation, OutOfWorld
Forum: Fast Simulation, Transportation & Others
Date: 27 Apr, 2004
From: Colin <cf@astro.soton.ac.uk>

Hi,

I am simulating a simple geometry - the experimentalHall is just air 
and is 4m cubed, inside this is a sand pit 120*120*30cm. I am starting
1461 keV photons at the centre of the sand pit and emitting them 
isotropically.

My simulation crashes and the last thing the log file tells me is:

*********************************************************************************************************
* G4Track Information:   Particle = e-,   Track ID = 3,   Parent ID = 1
*********************************************************************************************************

Step#    X(mm)    Y(mm)    Z(mm) KinE(MeV)  dE(MeV) StepLeng TrackLeng  NextVolume ProcName
    0      452     -599    -11.6     0.998        0        0         0    pit_phys initStep
    1      451     -600    -10.9     0.585    0.413     1.68      1.68     expHall Transportation
    2      451     -600    -10.9     0.585        0        0      1.68  OutOfWorld eBrem

3 things puzzle me about this log:

1) The final step is listed as OutOfWorld, when the position of the 
point (451,-600,-10.9) is very much within my world.

2) In the second step (#1) the transportation process is listed along 
side an energy deposit - is this supposed to happen? I thought by 
definition transportation didnt deposit any energy.

3) The final step has the process eBrem listed (not transportation) and 
has no energy deposit listed.

Can anyone shed any light on what has gone wrong here or am misunderstanding the log file?

Cheers,

Colin

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Weird bug - energy deposit from transportation plus OutOfWorld when really well inside it.   (Vladimir IVANTCHENKO - 27 Apr, 2004)
 Add Message Add Message
to: "Weird bug - energy deposit from transportation plus OutOfWorld when really well inside it."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]