Message: GetPreStepPoint / GetPostStepPoint confusion Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Sad GetPreStepPoint / GetPostStepPoint confusion 

Forum: Event and Track Management
Date: 12 Nov, 2010
From: Lukas Schulte <Lukas Schulte>

Hi all!

What happened to me is the following: My setup is basically a big block of ice with some identical PMTs placed by parameterized placement which are my sensitive detectors for Cherenkov photons. In my hits I want to store the copy no of the PMT that was hit. But when I tried to access and set the copy no via

newHit->SetDOMNo(aStep->GetPostStepPoint()->GetPhysicalVolume()->GetCopyNo());

I always got 0 because the physical volume that was returned was the world volume (I checked this by printing the name of the returned volume).

After a lot of frustrating work, I changed GetPostStepPoint() into GetPreStepPoint() just to see what would happen, and suddenly everything worked perfectly.

So my question is: is this a known bug or is there any purpose behind this? Or am I just too stupid?

Cheers, Lukas

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: GetPreStepPoint / GetPostStepPoint confusion   (Marc Verderi - 12 Nov, 2010)
1 Ok: Re: GetPreStepPoint / GetPostStepPoint confusion   (Lukas Schulte - 12 Nov, 2010)
1 More: Re: GetPreStepPoint / GetPostStepPoint confusion   (Gumplinger Peter - 16 Nov, 2010)
2 None: Re: GetPreStepPoint / GetPostStepPoint confusion   (michel maire - 17 Nov, 2010)
 Add Message Add Message
to: "GetPreStepPoint / GetPostStepPoint confusion"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]