Message: Not tracking secondary particles Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Not tracking secondary particles 

Forum: Event and Track Management
Date: 30 Jan, 2017
From: Beatriz Tapia <Beatriz Tapia>

We are using the Geant4 example of LXe, and are trying to extract the energy deposited by an incoming muon per step length. We use theStep->GetDeltaEnergy()/theCurrentTrack->GetStepLength() to print it out in the terminal.

The issue we have is that we have a lot of secondary particles produced. They slow down our simulation, but we do not need them at all. We just need the energy deposit into the medium + the energy needed to create the secondaries.

I wanted to check if GetDeltaEnergy() was the right function to use and if there is a way to accelerate the simulation without changing the energy deposit. My idea would be to create the secondaries, but not track them after that.

Thanks a lot for your help, Bea

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Not tracking secondary particles   (Gumplinger Peter - 30 Jan, 2017)
(_ Question: Re: Not tracking secondary particles   (Beatriz Tapia - 31 Jan, 2017)
(_ Feedback: Re: Not tracking secondary particles   (Gumplinger Peter - 31 Jan, 2017)
 Add Message Add Message
to: "Not tracking secondary particles"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]