Message: stepping error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question stepping error 

Forum: Event and Track Management
Date: 05 Jul, 2016
From: Jeremy McCormick <Jeremy McCormick>

Hello,

I'm getting the following error in my simulation after many thousands of events run successfully....

-------- WWWW ------- G4Exception-START -------- WWWW -------
*** G4Exception : GeomNav1002
      issued by : G4MultiLevelLocator::EstimateIntersectionPoint()
Many substeps while trying to locate intersection.
          Undertaken length: 295287 - Needed: 3972 substeps.
          Warning level = 1000 and maximum substeps = 10000
*** This is just a warning message. ***
-------- WWWW -------- G4Exception-END --------- WWWW -------

ERROR - G4MultiLevelLocator::EstimateIntersectionPoint()
        Start and end-point of requested Step:
Start         0 -62.141037 -242.15386  128.69337 -0.2353  0.2033 -0.9504       0         0         9.22 Init/NotKnown
       Current Position  and  Direction
Step#       s        X(mm)      Y(mm)      Z(mm)    N_x     N_y     N_z   Delta|N|   StepLen  StartSafety   PhsStep
   0  286581.25 -67483.449  58031.474 -272244.88 -0.2353  0.2033 -0.9504       0  2.87e+05         9.22 Init/NotKnown
        Start and end-point of current Sub-Step:

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : GeomNav0003
      issued by : G4MultiLevelLocator::EstimateIntersectionPoint()
Too many substeps!
         Convergence is requiring too many substeps: 10002
          Abandoning effort to intersect.
          Found intersection = 0
          Intersection exists = 1
        Undertaken only length: 1190 out of 286581 required.
        Remaining length = 285391
*** Fatal Exception *** core dump ***
-------- EEEE -------- G4Exception-END --------- EEEE -------

This is with the geant4-10-01-patch-02 version (I can update that to the current release if it would make any difference).

I ran the geometry overlap check and it reported no issues at all.

I assume it is a low energy secondary that is failing to step through a B-field.

Is there a setting that I can enable which would cause G4 to simply kill the stuck track instead of causing a crash? Or is there some other way to debug/fix this?

Thanks.

--Jeremy

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: stepping error   (Gabriele Cosmo - 05 Jul, 2016)
(_ None: Re: stepping error   (Jeremy McCormick - 06 Jul, 2016)
 Add Message Add Message
to: "stepping error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]