Message: G4 fail to find normal vector (only when a field is added). Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question G4 fail to find normal vector (only when a field is added). 

Forum: Event and Track Management
Date: 12 May, 2016
From: <Loris>

Hello every one,

When I add a field throught ConstructSDandField() I get the following warning message each time a particle (neutron) is reflected on a volume (if I remove the field, the message disappear).

-------- WWWW ------- G4Exception-START -------- WWWW -------
*** G4Exception : GeomNav0003
      issued by : G4Navigator::GetGlobalExitNormal()
 WARNING> Expected normal-global-frame to be valid,  i.e. a unit vector!
  - but |normal|   = 0  - and |normal|^2 = 0
 which differs from 1.0 by -1
   n = (0,0,0)
============================================================
   State of Navigator: 
The current state of G4Navigator is: 
  ValidExitNormal= 0
  ExitNormal     = (0,0,0)
  Exiting        = 0
  Entering       = 0
  BlockedPhysicalVolume= None
  BlockedReplicaNo     = -1
  LastStepWasZero      = 0

 Current Localpoint = (1240.1431,-648.65287,-2653.5438)
 PreviousSftOrigin  = (1240.143,-648.65276,-2653.5437)
 PreviousSafety     = 0.00013825384
Current History: 
Level=[0]: Phys Name=[World] Type=[N]
Level=[1]: Phys Name=[sphere_physical] Type=[N]

============================================================ Value obtained from stored global-normal is not a unit vector.

*** This is just a warning message. *** -------- WWWW -------- G4Exception-END --------- WWWW -------

(Here the geometry is just a sphere)

I have no idea where it comes from and if there is serious consequences on the reflection ?

Thanks in advance. Best Regards.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: G4 fail to find normal vector (only when a field is added).   (Gumplinger Peter - 12 May, 2016)
(_ None: Re: G4 fail to find normal vector (only when a field is added).   (Loris - 18 May, 2016)
 Add Message Add Message
to: "G4 fail to find normal vector (only when a field is added)."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]