Message: Re: gdb debug Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: gdb debug 

Forum: Event and Track Management
Re: Question gdb debug (Dipanwita Banerjee)
Re: Warning Re: gdb debug (Michael H. Kelsey)
Re: None Re: gdb debug (Dipanwita Banerjee)
Date: 04 Jul, 2013
From: Michael H. Kelsey <Michael H. Kelsey>

Dipanwita Banerjee writes:
> Hi i tried what you said but its still saying no debugging symbols
> found...

[ I had suggested using "-DCMAKE_BUILD_TYPE=Debug", case-sensitive... ]

> i have copied one of the examples to a different directory as i wanted
> to change few things in it so the path should be to that file right? i
> have tried all possibilities but it doesn't seem to work. Please let me
> know what I can do.

I will need to investigate this further.  My own build uses Debug, and I
have all the GDB debugging symbols present.  I will try a clean build, and
will also look at all of my CMAKE symbol defintions to see what's
happening.

I am copying Ben Morgan on this reply.  Ben, what is the correct way for a
user to install GEANT4 and have debugging symbols available?  I thought it
was the "Debug" build type, above.

      -- Michael Kelsey

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: gdb debug   (Dipanwita Banerjee - 04 Jul, 2013)
2 None: Re: gdb debug   (Ben Morgan - 05 Jul, 2013)
 Add Message Add Message
to: "Re: gdb debug"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]