Message: problems in particle tracking near interface Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question problems in particle tracking near interface 

Keywords: tracking particle interface problem
Forum: Event and Track Management
Date: 17 Sep, 2003
From: Luís Perles <Luís Perles>

Dear Geant4 users,

When tracking a 3MeV electron through a slab of teflon I get this strange behaviour:

************************************************************************************
*    Row   *   EventID *   TrackID * trackpoin * trackpoin * trackpoin * NextVolum *
************************************************************************************
*     8132 *      1695 *         1 * 0.0007072 * -0.000246 * -0.011962 *    Target *
*     8133 *      1695 *         1 * 0.0006322 * -0.000533 * -0.012277 *    Target *
*     8134 *      1695 *         1 * 0.0003625 * -0.000777 *   -0.0125 *     World *
*     8135 *      1695 *         1 * 0.0003486 * -0.000739 * -0.012492 *    Target *
*     8136 *      1695 *         1 * 0.0003483 * -0.000728 *   -0.0125 *     World *
************************************************************************************

Look that Event 1695 cross the interface twice, but my World volume is vacuum!

My program is based in novice example 02. I'm using this method to get NextVolume: aStep->GetPostStepPoint ()->GetPhysicalVolume ()->GetName ()

Am I doing something wrong or it is a bug of tracking class?

Thanks, Luís Perles

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "problems in particle tracking near interface"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]