Message: Re: Tracking of low energy muons stops without apparent reason Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: Tracking of low energy muons stops without apparent reason 

Forum: Event and Track Management
Re: Question Tracking of low energy muons stops without apparent reason (Kamil Sedlak)
Date: 02 Feb, 2012
From: Gumplinger Peter <Gumplinger Peter>

Hi Kamil,

Looking at your output, I see that:

#Step#      X         Y         Z        KineE    dEStep   StepLeng  TrakLeng    Volume     Process
 1082   -944 um   56.7 um    -10 cm     57 eV 3.86e-134 eV   1.12 mm   1.09 m    phys_target  Transportation

dEStep = 3.86e-134 eV

yet: Energy Deposit (MeV) : 5.398394121200206e-05

and: Kinetic Energy (MeV): 5.697403335775722e-05 0

I guess, the reason these don't 'add up' is the electric field. But even so I can't make complete sense of it. If the energy difference in the step is 0 (3.86e-134 eV) then I would expect that the field and energy loss exactly compensate, but then final kin. Energy should not be zero. There are many steps with extremely small dEStep.

But what puzzles me also is that you have phys_target Transportation and Step Status:Geom Limit but you are telling us that we aren't at the end of phys_target and haven't been for many steps. So, then what causes the 1mm steps.

We'll probably have to debug this off-line. Is this problem new with 9.5?

Cheers, Peter

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Tracking of low energy muons stops without apparent reason   (Kamil Sedlak - 03 Feb, 2012)
 Add Message Add Message
to: "Re: Tracking of low energy muons stops without apparent reason"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]