Message: Re: Problem with Quadrupole Magnetic Field!! Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Problem with Quadrupole Magnetic Field!! 

Forum: Fields: Magnetic and Otherwise
Re: Question Problem with Quadrupole Magnetic Field!! (S.Fonseca UERJ/Brazil)
Date: 25 Oct, 2005
From: John Apostolakis <John Apostolakis>

I suggest using the following methods of PropagatorInField to

  void    SetMaxLoopCount( G4int new_max );

to enable it to go further in case it is simply taking too many substeps in order to integrate in the much-varying field. The current default is 1000.

  G4int  SetVerboseLevel( G4int verbose );

if you give it a value of 2 or 3 it print some more information which could be useful in identifying the problem.

To find the G4PropagatorInField, please use the G4TransportationManager. Its method
   static G4TransportationManager* GetTransportationManager()
gives the singleton's pointer and the method
   G4PropagatorInField*  GetPropagatorInField() 
provides that.

If you can provide more information from these I will be glad to try to assist.

Best regards, John Apostolakis

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: Problem with Quadrupole Magnetic Field!!"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]