Message: Re: Problem with spin tracking in Geant4 10.0 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning Re: Problem with spin tracking in Geant4 10.0 

Forum: Fields: Magnetic and Otherwise
Re: Question Problem with spin tracking in Geant4 10.0 (Nik Berger)
Date: 17 Jan, 2014
From: Gumplinger Peter <Gumplinger Peter>

Thanks Nik,

for reporting this bug in G4.10.

Please, see the attachment for a corrected version of G4Mag_SpinEqRhs.cc

There is a new development tag - field-V10-00-00 - that fixes this problem. It will be included in the first correction patch p01 of G4.10.

To my defense, spin tracking was debugged before the release of 9.10 but unfortunately only with G4EqEMFieldWithSpin through the stringent test of example /extended/field/field05. So, in other words, users who've been using an EM field (a field with both B and E components) for their application of spin tracking are not affected by this bug in G4.10

Thank you again for reporting this, Peter

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2014/01/17/13.21-77444-G4Mag_SpinEqRhs.cc

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Problem with spin tracking in Geant4 10.0   (Nik Berger - 20 Jan, 2014)
 Add Message Add Message
to: "Re: Problem with spin tracking in Geant4 10.0"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]