Message: Problem with spin tracking in Geant4 10.0 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Problem with spin tracking in Geant4 10.0 

Forum: Fields: Magnetic and Otherwise
Date: 17 Jan, 2014
From: Nik Berger <Nik Berger>

Hi!
I do a simulation with slow muons and their decay electrons and would like to track the muon spin; in 4.9.6.p02 the following worked fine:

fpMagField = new G4UniformMagField(G4ThreeVector(0.0,0.0,1.0*tesla));
		G4Mag_EqRhs * fEquation = new G4Mag_SpinEqRhs(fpMagField);
		G4MagIntegratorStepper * pStepper = new G4ClassicalRK4(fEquation,12);
		G4ChordFinder * pChordFinder = new G4ChordFinder(fpMagField, 1e-2*mm, pStepper);
		G4TransportationManager::GetTransportationManager()->GetFieldManager()->SetDetectorField(fpMagField);
		G4TransportationManager::GetTransportationManager()->GetFieldManager()->SetChordFinder(pChordFinder);

in Geant4 10.0 however, my particles behave as if they were neutral (or as if 
there was no magnetic field, hard to tell...). If I replace G4Mag_SpinEqRhs with 
G4Mag_UsualEqRhs and use 6 variables only for the stepper, I am back to beautiful 
helices (but loose the spin tracking). Is this a bug or am I doing something 
wrong? Any help would be appreciated,

thanks

Nik

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Warning: Re: Problem with spin tracking in Geant4 10.0   (Gumplinger Peter - 17 Jan, 2014)
(_ Ok: Re: Problem with spin tracking in Geant4 10.0   (Nik Berger - 20 Jan, 2014)
 Add Message Add Message
to: "Problem with spin tracking in Geant4 10.0"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]