Message: Tracking in magnetic field Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Tracking in magnetic field 

Keywords: tracking
Forum: Fields: Magnetic and Otherwise
Date: 19 Jun, 2004
From: Jens Hasper <hasper@ikp.tu-darmstadt.de>

Hi,

I'm using Geant4 to track electrons in a magnetic field, which I implemented in the GetFieldValue-funtion. I'm having kind of a strange problem now. Below a certain energy of the electrons, these electrons are not tracked any more. I have visualized my setup and it looks as if the electrons are reflected by an invisible wall before they even get into the magnetic field. To analyse this problem I wrote down the field values, Geant4 asks for when the GetFieldValue-Function is used. The funny thing is, that these value look perfect and they fit quite nicely to the track of the electron I expect. That's strange because the electrons on the other side never enter the magnetic field. I prooved that by giving an output, whenever the electrons enter the magnetic field. But in that case, I received no output. Any idea, where there could be a conflict and how to solve this problem?

Thanks a lot,

Jens Hasper

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Tracking in magnetic field   (Jens Hasper - 20 Jun, 2004)
(_ None: Re: Tracking in magnetic field   (Tom Roberts - 20 Jun, 2004)
 Add Message Add Message
to: "Tracking in magnetic field"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]