Message: Re: Set up new field Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Set up new field 

Forum: Fields: Magnetic and Otherwise
Re: Question Set up new field (Andrea)
Re: Question Re: Set up new field (Andrea)
Date: 16 May, 2010
From: Andrea <Andrea>

Hi all, I used antiprotons instead of neutral antiatoms and that particles feel the field. Then I re-implemented the G4Transportation (as I should do from the beginning, following the manual) allowing for my field to exert a force. But, now, the output is

### Run 0 start. Start Run processing.

**********************************************************************************************
* G4Track Information:   Particle = Hbar,   Track ID = 1,   Parent ID = 0
**********************************************************************************************

Step#    X(mm)    Y(mm)    Z(mm) KinE(MeV)  dE(MeV) StepLeng TrackLeng NextVolume ProcName
    0     -320    -2.61     1.36  1.14e-13        0        0         0        cave initStep
    1     -320    -2.61     1.36  1.14e-13        0 1.8e+308  1.8e+308        cave User Limit
    2     -320    -2.61     1.36  1.14e-13        0 1.8e+308       inf        cave User Limit
    ...
    ...

and the step number rapidly reachs tens of thousands with the same content of the step#2. I argue that the problem is in the G4UserLimit, but I dont't know what a I should do. Help me, please.

Best regards Andrea

 Add Message Add Message
to: "Re: Set up new field"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]