Message: Modified microelectronics example not working Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Modified microelectronics example not working 

Forum: Documentation and Examples
Date: 27 Nov, 2017
From: Christopher Walker <Christopher Walker>

Hello,
   I am using geant4-10-02-patch-02 on Ubuntu and I am rather new to Geant4

   I would like to simulate low energy electrons in Si, so I have chosen the microelectronics example (from the advanced section) which works correctly.

  I need to look at the electrons backscattered from a sample, so I have increased the size of the world volume, used a sample a few 10s of microns thick and added a sensitive detector as is done in the B2 example. The sensitive detector is behind the position of the electron gun, and I should obtain electrons with energies less than the primary electron energy. I obtain hits in this sensitive detector in the output root file which I have examined using root. Thus far everything OK.

However, things are not right. When I run my test simulation, the graphics shows the detectors and target, but appears then disappears then appears, then disappears etc etc, but never shows any of the tracks. Also what I get in the output root file are electrons with the primary electron energy and electrons with exceedingly low energy, but nothing in between. Evidently the simulation is not functioning as I would expect. However, I am a bit stuck with regards to trying to fathom what is going on. e.g. - I cannot partially remove the sensitive detector to try to get back to the original example !. Can anyone suggest tips for trying to debug this situation ?

Thanks Chris

 Add Message Add Message
to: "Modified microelectronics example not working"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]