Message: Re: Qt5 Error in Examples Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Note Re: Qt5 Error in Examples 

Forum: Documentation and Examples
Re: None Qt5 Error in Examples (Joshua Ellis)
Date: 15 Oct, 2014
From: Garnier Laurent <Garnier Laurent>

Using both Qt4 and Qt5 is not a good practice. You will have a lot of problems finding libraries in standard library path (Qt4) and specific path (Qt5).

The recommanded way to build Geant4 with Qt5 is to set the CMAKE_PREFIX_PATH to match your Qt5 installation :

export CMAKE_PREFIX_PATH=where_is_qt/lib/cmake/

But, this could not work if you have both Qt5 and Qt4

Laurent

PS : Geant4 is fully compatible from Qt4.6 to Qt5.x and there is no benefits of using Qt5 with Geant4 !

 Add Message Add Message
to: "Re: Qt5 Error in Examples"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]