Message: G4MPImanager.cc failed to compile Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning G4MPImanager.cc failed to compile 

Forum: Documentation and Examples
Date: 22 Mar, 2012
From: Neoh <Neoh>

Hi,

I used to be able to build my application with MPI parallelization, but trying to compile with the geant4.9.5 version of mpi_interface give me these(pls see, in particular, line 122 of G4MPImanager.cc):

[neohys@localhost mpi_interface]$ make
Compiling G4MPImanager.cc ...
src/G4MPImanager.cc: In static member function ‘static G4MPImanager* G4MPImanager::GetManager()’:
src/G4MPImanager.cc:122:47: error: no matching function for call to ‘G4Exception(const char [29])’
src/G4MPImanager.cc:122:47: note: candidates are:
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:79:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, const char*)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:79:6: note: candidate expects 4 arguments, 1 provided
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:83:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, G4ExceptionDescription&)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:83:6: note: candidate expects 4 arguments, 1 provided
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:87:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, G4ExceptionDescription&, const char*)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:87:6: note: candidate expects 5 arguments, 1 provided
src/G4MPImanager.cc: In member function ‘void G4MPImanager::Initialize()’:
src/G4MPImanager.cc:133:53: error: no matching function for call to ‘G4Exception(const char [35])’
src/G4MPImanager.cc:133:53: note: candidates are:
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:79:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, const char*)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:79:6: note: candidate expects 4 arguments, 1 provided
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:83:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, G4ExceptionDescription&)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:83:6: note: candidate expects 4 arguments, 1 provided
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:87:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, G4ExceptionDescription&, const char*)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:87:6: note: candidate expects 5 arguments, 1 provided
src/G4MPImanager.cc: In member function ‘void G4MPImanager::ExecuteBeamOnThread(const G4String&)’:
src/G4MPImanager.cc:465:69: error: no matching function for call to ‘G4Exception(const char [49])’
src/G4MPImanager.cc:465:69: note: candidates are:
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:79:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, const char*)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:79:6: note: candidate expects 4 arguments, 1 provided
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:83:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, G4ExceptionDescription&)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:83:6: note: candidate expects 4 arguments, 1 provided
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:87:6: note: void G4Exception(const char*, const char*, G4ExceptionSeverity, G4ExceptionDescription&, const char*)
/home/neohys/geant4.9.5/source/global/management/include/globals.hh:87:6: note: candidate expects 5 arguments, 1 provided
make: *** [/home/neohys/geant4_workdir/tmp/Linux-g++/G4UImpi/G4MPImanager.o] Error 1


I cannot compile the MPI examples from source because of the error above.


Neoh

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Idea: Re: G4MPImanager.cc failed to compile   (Neoh - 22 Mar, 2012)
 Add Message Add Message
to: "G4MPImanager.cc failed to compile"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]