Message: Can't compile N01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Can't compile N01 

Forum: Documentation and Examples
Date: 06 Dec, 2010
From: Toma Badescu <Toma Badescu>

I have installed geant4 successfully, and i'm trying to run the first novice example:

 toma@toma-R1F:~/geant4/N01$ make
 Using granular libraries ...
 Linking exampleN01
 g++: exampleN01: No such file or directory
 make: *** [/home/toma/geant4/bin/Linux-g++/exampleN01] Error 1

I also tried running it from the ... /examples/novice/N01 directory.

My env.sh seems in order, LD_LIBRARY_PATH and CLHEP_LIB were set (before this i got the cannot find -lCLHEP.lib error)...

Also, i used to get the following error:

 Using granular libraries ...
 Linking exampleN01
 /usr/bin/ld: cannot find -l/home/toma/CLHEP/install/lib
 /usr/bin/ld: cannot find -lCLHEP.lib
 collect2: ld returned 1 exit status
 make: *** [/home/toma/geant4/bin/Linux-g++/exampleN01] Error 1

So i set the CLHEP_LIB to be CLHEP-2.1.0.1, and got rid of the second error. For the first one i went into the binmake.gmk file, found where this path (-l/home/toma ...) was and removed the -l from in front of it. Sounds silly, but i had no other ideea.

Now i'm stuck with the error in the first paragraph and i have no ideea what to do.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Can't compile N01   (Andreas Schaelicke - 14 Dec, 2010)
 Add Message Add Message
to: "Can't compile N01"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]