Message: Re: problem with compilation of advanced/xray_fluorescence for geant4.9.0.p01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: problem with compilation of advanced/xray_fluorescence for geant4.9.0.p01 

Keywords: geant4.9.0 xray fluorescence advanced example compilation error
Forum: Documentation and Examples
Re: None problem with compilation of advanced/xray_fluorescence for geant4.9.0.p01 (dusan)
Date: 25 Sep, 2007
From: J. David Wright <david.wright@yale.edu>

I get the same error when attempting to compile the xray fluorescence advanced example using the included GNUmakefile. That is,

include/XrayFluoDataSet.hh:84: error: conflicting return type specified for 'virtual void XrayFluoDataSet::LoadData(const G4String&)' /Applications/geant4.9.0/source/processes/electromagnetic/lowenergy/include/G4VEMDataSet.hh:70: error: overriding 'virtual G4bool G4VEMDataSet::LoadData(const G4String&)'

make: *** [tmp/Darwin-g++/XrayFluo/XrayFluoDataSet.o] Error 1

I am using Geant4.9.0 with the following configurations,

%uname -ra Darwin HeLiX.local 8.10.2 Darwin Kernel Version 8.10.2: Wed Jun 20 21:49:49 PDT 2007; root:xnu-792.22.6~1/RELEASE_I386 i386 i386

%gcc -v Using built-in specs.

Target: i686-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5367.obj~1/src/configure --disable-checking -enable-werror --prefix=/usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/lib --build=powerpc-apple-darwin8 --with-arch=nocona --with-tune=generic --program-prefix= --host=i686-apple-darwin8 --target=i686-apple-darwin8 Thread model: posix gcc version 4.0.1 (Apple Computer, Inc. build 5367)

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: problem with compilation of advanced/xray_fluorescence for geant4.9.0.p01   (alfonso.mantero@ge.infn.it - 27 Sep, 2007)
(_ None: Re: problem with compilation of advanced/xray_fluorescence for geant4.9.0.p01   (Kelly Rakes - 16 Dec, 2007)
 Add Message Add Message
to: "Re: problem with compilation of advanced/xray_fluorescence for geant4.9.0.p01"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]