Message: Re: Output of hadronic "Hadr01" extended example. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Output of hadronic "Hadr01" extended example. 

Forum: Documentation and Examples
Re: Question Output of hadronic "Hadr01" extended example. (Katherin Shtejer)
Re: None Re: Output of hadronic "Hadr01" extended example. (Adam)
Date: 24 May, 2007
From: Mark Donszelmann <Mark Donszelmann>

Hi

indeed this points to the fact that G4 was probably compiled with
a newer version than AIDAJNI-3.2.3.

You could try the latest AIDAJNI-3.2.6 which is compatible, but
probably compiled (see release notes) with a later compiler.

Or, you can compile the source code (w/o modifications) yourself.

The reason for all this trouble is the fact that g++ does NOT keep
their libstdc++ backward compatible over releases of g++.

Regards
Mark Donszelmann

On May 24, 2007, at 6:24 PM, Adam wrote:

> *** Discussion title: Documentation and Examples
> Email replies to PublicHyperNews@slac.stanford.edu must include:
>   In-Reply-To: <"/docsexamples/329/3"@geant4-hn.slac.stanford.edu>
>   Subject: ...change this to be about your reply.
>
> Hello, I am having the same error message as above:
>
> /usr/bin/ld: warning: libstdc++.so.5, needed by /home/blais/ 
> AIDAJNI-3.2.3//
> lib/Linux-g++/libAIDAJNI.so, may conflict with libstdc++.so.6
>
> I am getting the error in all examples that use AIDA. I understand  
> that
> AIDAJNI and Geant4 may be pointing to different versions of g++, but
> can you go into detail about exactly how I can fix this problem? (I'm
> not sure how I can manipulate the source code.)
>

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Output of hadronic "Hadr01" extended example.   (Adam - 24 May, 2007)
(_ None: Re: Output of hadronic "Hadr01" extended example.   (Mark Donszelmann - 24 May, 2007)
 Add Message Add Message
to: "Re: Output of hadronic "Hadr01" extended example."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]