Message: Re: LXe example, Segmentation fault Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning Re: LXe example, Segmentation fault 

Keywords: LXe, Segmentation fault
Forum: Documentation and Examples
Re: None LXe example, Segmentation fault (amaresh kumar)
Date: 14 Sep, 2006
From: Gumplinger Peter <Gumplinger Peter>

Hello Amaresh,

Thanks for pointing out this problem. It is a bug! I have reported it as bug #889 and fixed it in tag: LXe-V08-01-00

The fix is just one line. In LXeDetectorConstruction.cc please change the class constructor to read:

LXeDetectorConstruction::LXeDetectorConstruction()
: LXe_mt(NULL), MPTPStyrene(NULL)
{
  SetDefaults();
  detectorMessenger = new LXeDetectorMessenger(this);
}

It is quite clear that the compilers in the past must have assigned NULL by default to class members who are pointers, or else, we would have had this problem all along(?)

Best regards, Peter Gumplinger

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: LXe example, Segmentation fault   (amaresh kumar - 13 Oct, 2006)
1 Feedback: Re: LXe example, Segmentation fault   (Peter Gumplinger - 17 Oct, 2006)
5 None: Re: LXe example, Segmentation fault   (amaresh kumar - 13 Oct, 2006)
 Add Message Add Message
to: "Re: LXe example, Segmentation fault"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]