Message: error in HepMC/HepMCEx01 and HepMC/HepMCEx02 for geant4.8.1 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None error in HepMC/HepMCEx01 and HepMC/HepMCEx02 for geant4.8.1 

Forum: Documentation and Examples
Date: 03 Jul, 2006
From: dusan <dusan>

I am using SLC4 with gcc version 3.4.5 20051201 (Red Hat 3.4.5-2) and 
geant 4.8.1 and HepMC_Version1.25.
My first remark:  when I used geant4.8.0.p01 the examples  eventgenerator/HepMC/HepMCEx01 and
ventgenerator/HepMC/HepMCEx02 were o.k.
Now I have:
Compiling H02PrimaryGeneratorAction.cc ...
In file included from /kosice/hep_software/HepMC_Version1.25/HepMC/GenEvent.h:113,
                 from include/HepMCG4Interface.hh:39,
                 from include/HepMCG4AsciiReader.hh:35,
                 from src/H02PrimaryGeneratorAction.cc:37:
/kosice/hep_software/HepMC_Version1.25/HepMC/GenVertex.h:57: error: expected `,' or `...' before '&' token
/kosice/hep_software/HepMC_Version1.25/HepMC/GenVertex.h:59: error: ISO C++ forbids declaration of `HepLorentzVector' with no type
/kosice/hep_software/HepMC_Version1.25/HepMC/GenVertex.h:78: error: `HepLorentzVector' has not been declared
-----------------------------------------------------------------------

Dusan

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: error in HepMC/HepMCEx01 and HepMC/HepMCEx02 for geant4.8.1   (Gabriele Cosmo - 05 Jul, 2006)
 Add Message Add Message
to: "error in HepMC/HepMCEx01 and HepMC/HepMCEx02 for geant4.8.1"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]