Message: Problem Linking ExampleN01 with Red Hat Enterprise Linux WS Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Problem Linking ExampleN01 with Red Hat Enterprise Linux WS 

Forum: Documentation and Examples
Date: 16 May, 2005
From: San <San>

I'm now using Red Hat Enterprise Linux WS (version 3 update 4).
I seem to have successfully installed Geant4.7.0 into the system.
And, I’m using CLHEP 1.8.1.0.

When I’m trying to compile exampleN01, error occurred:
----------------------------------------------------------------------------------------------
[root@localhost N01]# gmake
Making dependency for file exampleN01.cc ...
Making dependency for file src/ExN01PrimaryGeneratorAction.cc ...
Making dependency for file src/ExN01PhysicsList.cc ...
Making dependency for file src/ExN01DetectorConstruction.cc ...
Compiling ExN01DetectorConstruction.cc ...
Compiling ExN01PhysicsList.cc ...
Compiling ExN01PrimaryGeneratorAction.cc ...
Creating/replacing object files in /root/geant4/tmp/Linux-g++/exampleN01/libexampleN01.a ...
Compiling exampleN01.cc ...
Using granular libraries ...
Linking exampleN01 ...
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libGLU.so when searching for -lGLU
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libGLU.a when searching for -lGLU
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libGL.so when searching for -lGL
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libGL.a when searching for -lGL
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libXmu.so when searching for -lXmu
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu
/usr/bin/ld: cannot find -lXmu
collect2: ld returned 1 exit status
gmake: *** [/root/geant4/bin/Linux-g++/exampleN01] Error 1
[root@localhost N01]#
----------------------------------------------------------------------------------------------

I’ve set the “OGLHOME” to “/usr”.
What is wrong with the compilation?

Please advise!  Thank you!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: Problem Linking ExampleN01 with Red Hat Enterprise Linux WS   (Gabriele Cosmo - 12 Jul, 2005)
 Add Message Add Message
to: "Problem Linking ExampleN01 with Red Hat Enterprise Linux WS"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]