Message: Re: Energy deposited by secondaries not adding up Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Energy deposited by secondaries not adding up 

Forum: Biasing and Scoring
Re: Question Energy deposited by secondaries not adding up
Re: None Re: Energy deposited by secondaries not adding up (michel maire)
Date: Jan 18, 09:25
From: <fceraudo>

Hello,

The example gives me results fully compatible to yours within the uncertainties (file attached). However, as long as my case is concerned, when I try to visualize the histograms of the deposited energy, I get the two attached files.

In root_10keV_700um.gif, you can see the histogram of the deposited energy for all the hits (step-GetTotalDepositedEnergy()), all events together. The production cut is the default one at 700 um. At this point, I personally cannot tell if something is wrong: I see a large peak at 1.8 keV, i.e. the Si K-edge energy, which I guess is expected (...?), and all the deposited energies are below 10 keV, which is definitely expected, since we are dealing with secondaries.

When I try to combine the hits according to their event ID, I obtain screen_10keV_700um.png, which shows a peak just below 10 keV (which already seems low, given the thickness of the detector, but now it is not my main concern). In addition to this, we see a sort of "background" around the peak as well as two smaller peaks, apparently symmetric with respect to 10 keV, one of which is above 10 keV! This means that the total deposited energy is higher than the primary energy. In screen_10keV_1um.png, the same histogram is plotted, this time after applying a region with production but of 1 um to the logical volume of the detector.

How is this possible? What are those symmetric peaks?

I am using geant4-10-04-patch-02 [MT], if it matters somehow.

Thank you again.

Francesco

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2019/01/18/09.24-1886-root_10keV_700um.gif
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2019/01/18/09.24-40600-screen_10keV_1um.png
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2019/01/18/09.24-20648-screen_10keV_700um.png
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2019/01/18/09.24-61425-test.out

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Energy deposited by secondaries not adding up   (michel maire - Jan 18, 10:40)
 Add Message Add Message
to: "Re: Energy deposited by secondaries not adding up"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews