Message: Re: BremssstrahlungSplitting not working in Version 10.0 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Idea Re: BremssstrahlungSplitting not working in Version 10.0 

Forum: Biasing and Scoring
Re: None BremssstrahlungSplitting not working in Version 10.0
Date: 19 Mar, 2014
From: Vladimir Ivanchenko <Vladimir Ivanchenko>

Hello,

Some comments:

1) bremsstrahlung splitting does work if one uses EM built-in biasing options both in 9.6 and 10.0. To enable these option you need to use EN physics builders or reference Physics Lists and not to use WrapperProcess approach at all.

2) WrapperProcess is the more general approach addressing many biasing methods. This provides several different possibilities which are beyond EM built-in options. With version 10.0 this biasing framework was significantly extended but it is new and may indeed has problems.

Concerning your problem I would expect that WrapperProcess is written by you for your application. I do not think that WrapperProcess is optimal for bremsstrahlung splitting - you will have less problems using reference Physics List and existing built-in command.

Independently on what you decide further, please, send bug report to Geant4 bug report system, because this crash may happens in other circumstances for other users as well. The trace you have shown gives some hint but is not enough to understand the problem. We know for sure that bremsstrahlung is initialized normally for all other Geant4 tests/examples. So, without looking in all details of an application we cannot conclude.

VI

 Add Message Add Message
to: "Re: BremssstrahlungSplitting not working in Version 10.0"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews