Message: Re: Problem creating histos in TestEm5 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Problem creating histos in TestEm5 

Forum: Analysis
Re: Question Problem creating histos in TestEm5 (Steven Avery)
Date: 09 Sep, 2004
From: <vnivanch@mail.cern.ch>

On Wed, 8 Sep 2004, Steven Avery wrote:

> *** Discussion title: Analysis
> Email replies to PublicHyperNews@slac.stanford.edu must include:
>   In-Reply-To: <"/analysis/83"@geant4-hn.slac.stanford.edu>
>   Subject: ...change this to be about your reply.
> 
> I'm working (geant4.6.1) on windows with AIDAJNI/JAIDA and example
> TestEm5. I uncommented the analysis use line in the makefile. I'm using
> Wired for visualization. The problem I'm having is that it will not
> create histograms. The program crashes before it generates events. I get
> the message:
> 
> /testem/histo/setFileName shen3.aida
> 
> Loaded linked in JVM
> 
> /testem/histo/setHisto 5 100 0.00 0.004 deg
> 
> -> then it crashes
> 
> I had a similiar problem when using example testEm7. IAnalysisFactory
> was deleted after the histograms were created, but the implementation
> requires that the analysis factory not be deleted until the end of the
> job. Is this what's happening here? If so, how do I fix it for this
> example?
> 

Please look into histogram implementation in TestEm9 or in TestEm3, in
which factories are not deleted, auto_ptr are used. It should work for
JAIDA.

VI

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Problem creating histos in TestEm5   (Steven Avery - 09 Sep, 2004)
(_ None: RE: Problem creating histos in TestEm5   (tony_johnson@slac.stanford.edu - 09 Sep, 2004)
(_ None: RE: Problem creating histos in TestEm5   (michel maire - 10 Sep, 2004)
(_ None: RE: Problem creating histos in TestEm5   (Tony Johnson - 10 Sep, 2004)
(_ Question: Re: RE: Problem creating histos in TestEm5   (Lorena Magallanes - 27 Aug, 2009)
 Add Message Add Message
to: "Re: Problem creating histos in TestEm5"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]