Message: Problem Running A01 & TestEm4 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Problem Running A01 & TestEm4 

Keywords: A01, TestEm4, segmentation violation
Forum: Analysis
Date: 28 May, 2004
From: <aria00@hotmail.com>

Hi everyone!
I setup JAIDA & AIDAJNI then use A01 & TestEm4 for a test.
No problem compiling or linking, but when running I get error information
like this,
*******************************************************************
phot:  Total cross sections from Sandia parametrisation.
0x413afd80
0x413afc80
0x413af880
0x413af780
0x414f03a0
0x414ef3a0
0x414f07a0
0x414ef7a0
0x414f08a0
0x414ef8a0
0x414f0ca0
0x414efca0
0x414f02a0
0x414ef2a0
Loaded linked in JVM.
Warning: Cannot find callback list in XtAddCallback
Warning:
    Name: frame_canvas
    Class: XDrawingArea
    Creating an active drop site with no drop procedure.

ITree: Could not find method: findTree(Ljava/lang/String;)Lhep/aida/ITree;
ITuple: Could not find method: columnNames()[Ljava/lang/String;
ITuple: Could not find method: columnTypes()[Ljava/lang/Class;
Exception in thread "main" java.lang.NoSuchMethodError: columnNames
internal: Could not find class: java/lang/Integer

 *** Break *** segmentation violation
 Generating stack trace...
/usr/bin/addr2line: A01app: No such file or directory
/usr/bin/addr2line: A01app: No such file or directory
 0x4339809f in JVM_handle_linux_signal + 0x39f from /home/gh/jre/lib/i386/client/libjvm.so
 0x433970a8 in <unknown> from /home/gh/jre/lib/i386/client/libjvm.so
 0x437d45c0 in <unknown> from /lib/tls/libc.so.6
 0x430f8e2d in JAIDA::JITuple::JITuple[in-charge](JNIEnv_*, _jobject*, JAIDA::ProxyFactory const&) + 0x286b from /home/gh/AIDAJNI-3.2.1/lib/Linux-g++/libAIDAJNI.so
 0x43103d68 in JAIDA::ProxyFactory::createITuple(JNIEnv_*, _jobject*) const + 0x38 from /home/gh/AIDAJNI-3.2.1/lib/Linux-g++/libAIDAJNI.so
 0x430ff81a in JAIDA::JITupleFactory::create(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) + 0x64c from /home/gh/AIDAJNI-3.2.1/lib/Linux-g++/libAIDAJNI.so
 0x4003e56f in A01EventAction::A01EventAction[in-charge]() + 0xa39 from /home/gh/geant4.6.1/tmp/Linux-g++/A01app/libA01app.so
 0x08049c56 in main + 0x146 from A01app
 0x437c2574 in __libc_start_main + 0xe4 from /lib/tls/libc.so.6
 0x08049a81 in operator new(unsigned) + 0x31 from A01app
Aborted
*******************************************************************
Anyone knows what the problem is?
Thanks!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Problem Running A01 & TestEm4   (Mark Donszelmann - 01 Jun, 2004)
(_ None: Re: Problem Running A01 & TestEm4   (aria00@hotmail.com - 02 Jun, 2004)
(_ None: Re: Problem Running A01 & TestEm4   (Mark Donszelmann - 02 Jun, 2004)
(_ None: Re: Problem Running A01 & TestEm4   (aria00@hotmail.com - 02 Jun, 2004)
 Add Message Add Message
to: "Problem Running A01 & TestEm4"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]