Message: Geant4 program didn't write Ntuple into the root file Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Geant4 program didn't write Ntuple into the root file 

Forum: Analysis
Date: 14 Sep, 2016
From: Hubert Hu <Hubert Hu>

Please anyone can help me?

I create and fill up the Ntuple like the example B5 did.

But when I use the root program to open my output root file. It shows a tree with the right name and the columns I've created. But when I double click any of the column, root reports a error: "Bad numerical expression:"

Then I set the verbose to 4 and check the Geant4 program output. I've found all all the columns are correctly filled up. But at last step of writing into root file, there is only message about histograms (I also created some h1,h2,h3 histogram) and no sign of ntuple. I think this is the source of program. The program didn't write the filled ntuple into the root file.



I'm using the Geant4 10.01 patch01 and running the program at single thread mode.

Thanks,

Hubert

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Geant4 program didn't write Ntuple into the root file   (Hubert Hu - 15 Sep, 2016)
(_ None: Re: Geant4 program didn't write Ntuple into the root file   (Ivana Hrivnacova - 16 Sep, 2016)
 Add Message Add Message
to: "Geant4 program didn't write Ntuple into the root file"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]