Message: Re: Problems Compiling A01app Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Problems Compiling A01app 

Keywords: Compiling A01
Forum: Analysis
Re: Question Problems Compiling A01app (Francisco Garcia)
Re: None Re: Problems Compiling A01app (Mark Donszelmann)
Re: None Re: Problems Compiling A01app (Francisco Garcia)
Re: None Re: Problems Compiling A01app (Mark Donszelmann)
Re: None Re: Problems Compiling A01app (Francisco Garcia)
Date: 09 Dec, 2003
From: Mark Donszelmann <Mark Donszelmann>

Hi

now that you have AIDAJNI compiled, you got a problem starting with the message:

An unexpected exception has been detected in native code outside the VM. Unexpected Signal : 11 occurred at PC=0x4DD351DD Function=_XmAddHashEntry+0x15 Library=/usr/java/j2sdk1.4.2_02/jre/lib/i386/libawt.so

Current Java thread:
	at sun.awt.motif.MWindowPeer.pCreate(Native Method)
	at sun.awt.motif.MWindowPeer.create(MWindowPeer.java:79)
	at sun.awt.motif.MComponentPeer.init(MComponentPeer.java:222)
	at sun.awt.motif.MWindowPeer.init(MWindowPeer.java:90)
	at sun.awt.motif.MFramePeer.<init>(MFramePeer.java:58)
	at sun.awt.motif.MToolkit.createFrame(MToolkit.java:209)
	at java.awt.Frame.addNotify(Frame.java:472)
	- locked <0x45fdfc68> (a java.awt.Component$AWTTreeLock)
	at java.awt.Window.pack(Window.java:436)
	at hep.aida.ref.plotter.Plotter.show(Plotter.java:115)

You need to make sure NOT to link in OpenGL (Linux). There are flags to do so in G4. You only need to recompile and relink A01. The flag is called something like G4_USE_OPENGL...

The releasenotes say the following:

IMPORTANT: Make sure you do not link in OPENGL libraries since they 
pre-load libXt.so, which will make the JavaVM crash when it tries to open its first Window/Frame. This does NOT apply to the Windows Operating System of course. This bug was reported to Sun Microsystems as early as JDK 1.3.1, but will not be fixed until JDK 1.5 comes out. Bugnumber 4638291

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: Problems Compiling A01app"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]