Message: Missing libraries using "make" on SH shell Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Missing libraries using "make" on SH shell 

Forum: Analysis
Date: 14 Apr, 2010
From: Elin Aronsen <Elin Aronsen>

----------MB_8CCAA16255E0697_1D9C_1E56C_webmail-d093.sysops.aol.com
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="us-ascii"

=20
I am using Geant4_9_2_p01, cygwin and MSVC++ .NET 2003 on Windows XP Profe=
ssional with AIDAJNI (3.2.0), JAIDA (3.2.0) and JAVA 1.5.0 including osc_b=
atch_v16r0-cygwin-i386-gcc-344 to save and create histograms. I do
not get an object file on "make", see attached. Doing "make --warning-unde=
fined-variables", I get listed some
undefined variables starting with:G4MAKESHLIB, then G4LIB_BUILD_SHARED etc=
, see attached. How do I get the libs ? Did I do a mistake on installing=
 Geant4_9_2_p01 on cygwin.bat shell when I have to use a Bourne again shel=
l (bash or sh shell)? I am using an SH shell script to set up the VC++ com=
piler. Can anyone please help me telling me if the statement I am using to=
 set up the compiler options is correct:
set CL=3D /EHsc/W3/MD/GR/Fo"Debug/"/link/INCREMENTAL:YES/I\INCLUDE\LIB\Bin=
Mode.OBJ
or do you have any suggestions about how to make it better (when needing=
 an object file). Thanking
you very much for all help.
Elin Aronsen









----------MB_8CCAA16255E0697_1D9C_1E56C_webmail-d093.sysops.aol.com
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset="us-ascii"

<font color=3D'black' size=3D'2' face=3D'arial'><FONT color=3Dblack size=
=3D2 face=3Darial>&nbsp;

<div id=3DAOLMsgPart_3_c5ef2c56-a390-4590-b7ec-534e788b510a>

<div>I am using&nbsp;Geant4_9_2_p01, cygwin and MSVC++ .NET 2003 on Window=
s XP Professional with AIDAJNI (3.2.0), JAIDA (3.2.0) and JAVA 1.5.0 inclu=
ding osc_batch_v16r0-cygwin-i386-gcc-344 to save and create histograms. I=
 do</div>


<div>not get an object file on "make", see attached. Doing "make --warning=
-undefined-variables", I get listed some</div>


<div>undefined variables starting with:G4MAKESHLIB, then G4LIB_BUILD_SHARE=
D etc, see attached. How do I get the libs ? Did I do a mistake on install=
ing Geant4_9_2_p01 on cygwin.bat shell when I have to use a Bourne again=
 shell (bash or sh shell)? I am using an SH shell script to set up the VC+=
+ compiler. Can anyone please help me telling me if the statement I am usi=
ng to set up the compiler options is correct:</div>
<FONT size=3D2>

<div>set CL=3D /EHsc/W3/MD/GR/Fo"Debug/"/link/INCREMENTAL:YES/I\INCLUDE\LI=
B\BinMode.OBJ</div>
</FONT>

<div>or do you have any suggestions about how to make it better (when need=
ing an object file). Thanking</div>


<div>you very much for all help.</div>


<div>Elin Aronsen</div>


<div><br>
<br>
<br>
<br>
</div>


<div style=3D"CLEAR: both"></div>
</FONT></div>
<br>


<div style=3D"CLEAR: both"></div>
</font>

----------MB_8CCAA16255E0697_1D9C_1E56C_webmail-d093.sysops.aol.com--

 Add Message Add Message
to: "Missing libraries using "make" on SH shell"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]