Message: How can I build through the G4Lab package of Openscientst 16.9 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None How can I build through the G4Lab package of Openscientst 16.9 

Forum: Analysis
Date: 30 Mar, 2010
From: Ming Shenjin <Ming Shenjin>

HI, everyone! I have a problem on the installation of the osc 16.9. I use Red Hat Enterprise Linux Version 5.1 with gcc 4.1.2, and Geant4.9.2beta. I tried to build the osc_vis from source. But when I try to build the G4lab package via ./sh/build -group Geant4 It gives an error and quit. The error shows:

/usr/bin/ld: /usr/local/geant4.9.2beta/geant4.9.2.b01/lib/Linux-g++/libG4run.a(G4RunManager.o): relocation R_X86_64_32 against `G4CountedObject<G4VTouchable>::aCountedObjectAllocator' can not be used when making a shared object; recompile with -fPIC

/usr/local/geant4.9.2beta/geant4.9.2.b01/lib/Linux-g++/libG4run.a: could not read symbols: Bad value

collect2: ld returned 1 exit status

[1]+ Exit 127

And the environment of my Geant4 installation is listed below:

On this machine the G4SYSTEM=Linux-g++

On this machine the G4INSTALL=/usr/local/geant4.9.2beta/geant4.9.2.b01

On this machine the G4INCLUDE=/usr/local/geant4.9.2beta/geant4.9.2.b01/include/

On this machine the G4LIB=/usr/local/geant4.9.2beta/geant4.9.2.b01/lib

On this machine the G4LEVELGAMMADATA=/usr/local/geant4.9.2beta/geant4.9.2.b01 /data/PhotonEvaporation2.0

On this machine the G4RADIOACTIVEDATA=/usr/local/geant4.9.2beta/geant4.9.2.b01/data/RadioactiveDecay3.2

On this machine the G4LEDATA=/usr/local/geant4.9.2beta/geant4.9.2.b01/data/G4EMLOW6.1

On this machine the G4NEUTRONHPDATA=/usr/local/geant4.9.2beta/geant4.9.2.b01/data/G4NDL3.12

On this machine the G4ABLADATA=/usr/local/geant4.9.2beta/geant4.9.2.b01/data/G4ABLA3.0

On this machine the CLHEP_BASE_DIR=/usr/local/CLHEP

On this machine the CLHEP_INCLUDE_DIR=/usr/local/CLHEP/include

On this machine the CLHEP_LIB_DIR=/usr/local/CLHEP/lib

On this machine the CLHEP_LIB=CLHEP

On this machine the G4ANALYSIS_USE=1

On this machine the XMFLAGS=

On this machine the XMLIBS=

On this machine the XMFLAGS=

On this machine the XAWFLAGS=

On this machine the XAWLIBS=

On this machine the G4LIB_BUILD_STATIC=1

On this machine the G4LIB_USE_GRANULAR=1

On this machine the G4UI_USE_TCSH=1

Can anyone tell me how to resolve this problem!

Many thanks!

sam

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: How can I build through the G4Lab package of Openscientst 16.9   (Ming Shenjin - 30 Mar, 2010)
 Add Message Add Message
to: "How can I build through the G4Lab package of Openscientst 16.9"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]