Message: OpenScientist installation problems Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None OpenScientist installation problems 

Forum: Analysis
Date: 27 Feb, 2009
From: <Santos>

I am trying to install OpenScientist on a Ubuntu 7.10 machine with Geant4 and CLHEP already installed. I wanted the osc-vis package; to be on the safe side I decided to install from source.

I followed procedure described on the web site http://openscientist.lal.in2p3.fr/, in the "build from source" part.

1) Unzipped OpenScientist

2) Switched to OpenScientist/16.8/osc_vis/16.8/obuild directory

3) Ran . ./setup.sh (I use BASH)

4) Ran ./sh/build

I was able to get through most of the installation without much of a problem (Synaptic/apt-get in Ubuntu are great). The real problem came when the system tried to build the geant4 part. It tries to find CLHEP in /usr/local/CLHEP/2.0.3.2 and certainly fails (well, at some point I put a link to my CLHEP, version 2.0.4.0 there, it was satisfied but got stuck with some other problem on geant4).

As it is recommended on the site, I went to OpenScientist/16.8/foreign/v1r7p0 and edited CLHEP.obuild:

<variable name="CLHEP_home" platform="UNIX">PUT REAL PATH HERE</variable>

and also, just in case

<native_version>PUT MY VERSION HERE</native_version>

Still, I get the same: "WARNING : CLHEP not found under /usr/local/CLHEP/2.0.3.2" message. This is even more surprising because I changed the message, so, even if the system somehow looks into /usr/local/CLHEP/2.0.3.2, the message should look different. Then I also tried to find where else in the package there is a phrase "WARNING : CLHEP not found under ..." and could not. Now I am really stuck and puzzled.

Could somebody, please, tell me what is going on and how to fix this. Thank you, Slava

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: OpenScientist installation problems - SOLVED   (Santos - 03 Mar, 2009)
 Add Message Add Message
to: "OpenScientist installation problems"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]