Message: Lost in OpenScientist installation Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Lost in OpenScientist installation 

Keywords: Analysis, OpenScientist
Forum: Analysis
Date: 18 Jun, 2002
From: Alain Ferragut <Alain Ferragut>

Hi, I try to install OpenScientist on my LinuxMandrake8.1 system. It seems that the rpm package does not work on such system, as it was pointed out on LAL web site. Therefore, I try to install OpenScientist/v8 from scratch but it is not straightforward...Any help would be highly appreciated. Let me start at the beginning. I have all required packages installed : python2.1, mesa, freetype, motif, CLHEP1.7.0.0. Except CLHEP, all packages are rpm rebuilt from my Linux distribution or from web (motif). I rebuilt CLHEP from scratch and it works well with my G4 kernel. Therefore, I assume all the "basic" packages are well installed. I untarred OSC-v8 file from a directory located at $HOME/OSC/v8. I've just created this directory for this purpose. Therefore, I declared $HOME/OSC/v8 as the root in the install.sh script, which is located in OpenScientist/v8/install. Since I want to use G4, I included the G4packages in the packs='<package names>' variable. I uncommented the necessary lines of this script in order to use these packages. The CMT package is rebuilt and seems ok. Now comes the interface configuration and the installation of the other packages. Basically, I have some problems to understand what I have to change in the requirements files. What does "macro" mean? For instance, I have my OpenGL include files (glu.h..etc) located in /usr/X11R6/include/GL. The libraries are located in /usr/X11R6/lib. What do I have to write in the requirement file of OpenGL package ? Should I edit all the requirement files for all the packages or just some of them ? I already tried to rebuild all the packages I need, but it was catastrophic... Many warnings, many unknown files...No good. Thanks very much for any tips..!

                                 Alain

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Lost in OpenScientist installation   (Guy Barrand - 18 Jun, 2002)
 Add Message Add Message
to: "Lost in OpenScientist installation"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]