Message: Re: Geant4 Analysis Compiling Error - Correct GNUmakefile Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Geant4 Analysis Compiling Error - Correct GNUmakefile 

Forum: Analysis
Re: Question Geant4 Analysis Compiling Error
Re: None Re: Geant4 Analysis Compiling Error (Mark Donszelmann)
Re: None Re: Geant4 Analysis Compiling Error
Date: 18 Feb, 2005
From: <hsanjeewa1@gsu.edu>

Hi,

Here is my complete GNUmake file.

name := ECRS
G4TARGET := $(name)
USE_SPHERICAL :=1
#NOUSE_BIC_LIGHTION :=1
                                                                           
include $(G4INSTALL)/config/architecture.gmk
                                                                           
                                                                           
G4ANALYSIS_USE :=1
G4EXLIB := true
                                                                           
CPPFLAGS += -I$(LISTS_BASE)/lists/Packaging/include
CPPFLAGS += -I$(LISTS_BASE)/lists/LHEP/include
CPPFLAGS += -L./lib -L$(G4LIB)/.lists_build/Linux-g++
                                                                           
EXTRALIBS := -lLHEP -lEcrs
ifdef G4ANALYSIS_USE
CPPFLAGS += `aida-config --include`
EXTRALIBS +=`aida-config --libs`
endif
EXTRALIBS += -lPackaging  -lg2c
                                                                           
ifdef  USE_SPHERICAL
CPPFLAGS += -DUSE_SPHERICAL
endif
ifdef NOUSE_BIC_LIGHTION
CPPFLAGS += -DNOUSE_BIC_LIGHTION
endif
CPPFLAGS += -g
                                                                           
ifndef G4INSTALL
  G4INSTALL = ../../..
endif
                                                                           
.PHONY: all
all: lib bin
                                                                           
                                                                           
include $(G4INSTALL)/config/binmake.gmk
                                                                           


Sanjeewa

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: Geant4 Analysis Compiling Error - Correct GNUmakefile"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]