Message: invalid pointer when switched to Multithreading Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None invalid pointer when switched to Multithreading 

Forum: Multithreading
Date: 22 Jun, 2015
From: Tracy Sanders <Tracy Sanders>

I've been attempting to convert my simulation over to multithreading. I was able to get it to run and it is able to use all of my cores, but when the simulation is closed I get a free() invalid pointer error. I'm not sure if this is caused by some deletion process or what.

I have added the terminal output of the non-multithreading and the multithreading.

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/06/22/08.48-26533-non-multithreading.txt
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/06/22/08.48-1212-multithreading.txt

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: invalid pointer when switched to Multithreading   (Tracy Sanders - 23 Jun, 2015)
(_ None: Re: invalid pointer when switched to Multithreading   (Makoto Asai - 23 Jun, 2015)
(_ None: Re: invalid pointer when switched to Multithreading   (Tracy Sanders - 23 Jun, 2015)
(_ None: Re: invalid pointer when switched to Multithreading   (Makoto Asai - 23 Jun, 2015)
(_ Ok: Re: invalid pointer when switched to Multithreading   (Tracy Sanders - 24 Jun, 2015)
(_ More: Re: invalid pointer when switched to Multithreading   (Tracy Sanders - 24 Jun, 2015)
(_ None: Re: invalid pointer when switched to Multithreading   (Makoto Asai - 24 Jun, 2015)
(_ None: Re: invalid pointer when switched to Multithreading   (Tracy Sanders - 24 Jun, 2015)
(_ None: Re: invalid pointer when switched to Multithreading   (Makoto Asai - 24 Jun, 2015)
 Add Message Add Message
to: "invalid pointer when switched to Multithreading"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews