Message: Re: Multi-threading mode problem Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Multi-threading mode problem 

Forum: Multithreading
Re: Question Multi-threading mode problem (Alex Kav)
Date: 20 Jun, 2017
From: Emanuele <Emanuele>

Hello,

Actually, even if i followed the manual on the twiki I still have the same problem when executing

DEBUG: end of PrimaryGeneratorAction::PrimaryGeneratorAction()

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : Run0123
      issued by : G4MTRunManager::SetUserAction()
For multi-threaded version, define G4VUserPrimaryGeneratorAction in G4VUserActionInitialization.
*** Fatal Exception *** core dump ***
-------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution *** Abort trap: 6

actually i defined a PrimaryGenerstorAction in my actionInitialization

void ActionInitialization::BuildForMaster() const
{
  SetUserAction(new RunAction((HistoManager*) fHisto));
}

//....oooOO0OOooo........oooOO0OOooo........oooOO0OOooo........oooOO0OOooo......

void ActionInitialization::Build() const {

  SetUserAction(new PrimaryGeneratorAction((int)seed));
  SetUserAction(new HistoManager((int)select,(DetectorConstruction*)fDetConstructor));
  SetUserAction(new RunAction((HistoManager*) fHisto));
  SetUserAction(new EventAction((RunAction*)fRunAction,(HistoManager*)fHisto,(DetectorConstruction*)fDetConstruction,(bool)pixelflag));
  SetUserAction(new SteppingAction((DetectorConstruction*)fDetConstruction,(EventAction*)fEventAction,(HistoManager*) fHisto,(bool)pixelflag));
}

and in the main

runManager->SetUserInitialization(new ActionInitialization((DetectorConstruction*)detector,(HistoManager*) histo ,(RunAction*)run_action,(EventAction*)event_action, (bool)pixelflag,(int)select,(int) seed));

is there something I'm missing?

thanks for your help

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Multi-threading mode problem   (Andrea Dotti - 20 Jun, 2017)
(_ None: Re: Multi-threading mode problem   (Emanuele - 20 Jun, 2017)
(_ None: Re: Multi-threading mode problem   (Andrea Dotti - 23 Jun, 2017)
 Add Message Add Message
to: "Re: Multi-threading mode problem"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews