Message: Re: Why Multithreaded compiler not working Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Why Multithreaded compiler not working 

Forum: Multithreading
Re: Question Why Multithreaded compiler not working (matthew)
Re: Warning Re: Why Multithreaded compiler not working (Andrea Dotti)
Date: 05 Feb, 2015
From: matthew <matthew>

Hello Andrea,

So I'm not sure my Geant distribution is setup to compile multithreaded. When I compile with VERBOSE=1, I get the following message:

S974566:Fluor_5-build mallen$ make VERBOSE=1 "/Applications/CMake 2.8-12.app/Contents/bin/cmake" -H/Users/mallen/G4Tree/G4Work/Fluor_5-build -B/Users/mallen/G4Tree/G4Work/Fluor_5-build --check-build-system CMakeFiles/Makefile.cmake 0 "/Applications/CMake 2.8-12.app/Contents/bin/cmake" -E cmake_progress_start /Users/mallen/G4Tree/G4Work/Fluor_5-build/CMakeFiles /Users/mallen/G4Tree/G4Work/Fluor_5-build/CMakeFiles/progress.marks /Applications/Xcode.app/Contents/Developer/usr/bin/make -f CMakeFiles/Makefile2 all /Applications/Xcode.app/Contents/Developer/usr/bin/make -f CMakeFiles/Fluor_5exec.dir/build.make CMakeFiles/Fluor_5exec.dir/depend cd /Users/mallen/G4Tree/G4Work/Fluor_5-build && "/Applications/CMake 2.8-12.app/Contents/bin/cmake" -E cmake_depends "Unix Makefiles" /Users/mallen/G4Tree/G4Work/Fluor_5-build /Users/mallen/G4Tree/G4Work/Fluor_5-build /Users/mallen/G4Tree/G4Work/Fluor_5-build /Users/mallen/G4Tree/G4Work/Fluor_5-build /Users/mallen/G4Tree/G4Work/Fluor_5-build/CMakeFiles/Fluor_5exec.dir/DependInfo.cmake --color= /Applications/Xcode.app/Contents/Developer/usr/bin/make -f CMakeFiles/Fluor_5exec.dir/build.make CMakeFiles/Fluor_5exec.dir/build make[2]: Nothing to be done for `CMakeFiles/Fluor_5exec.dir/build'. "/Applications/CMake 2.8-12.app/Contents/bin/cmake" -E cmake_progress_report /Users/mallen/G4Tree/G4Work/Fluor_5-build/CMakeFiles 1 2 3 4 5 6 7 [100%] Built target Fluor_5exec "/Applications/CMake 2.8-12.app/Contents/bin/cmake" -E cmake_progress_start /Users/mallen/G4Tree/G4Work/Fluor_5-build/CMakeFiles 0 S974566:Fluor_5-build mallen$

Doesn't that mean I'm not set up for multithreading? What do I need to do to fix the issue? matt

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Why Multithreaded compiler not working   (Andrea Dotti - 05 Feb, 2015)
(_ None: Re: Why Multithreaded compiler not working   (matthew - 05 Feb, 2015)
 Add Message Add Message
to: "Re: Why Multithreaded compiler not working"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews