Message: Why Multithreaded compiler not working Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Why Multithreaded compiler not working 

Forum: Multithreading
Date: 04 Feb, 2015
From: matthew <matthew>

I'm running GEANT4 10.0.1 on a MacOSX 10.9.5 and I'm having trouble getting the compiler to compile uses multithreading.

For some reason, I'm getting the following message when I compile:

user$cmake -DCMAKE_CXX_COMPILER=clang++ -DCMAKE_C_COMPILER=clang -DGEANT4_BUILD_MULTITHREADED=ON -DGeant4_DIR=~/G4Tree/geant4.10.00-install/lib/Geant4-10.0.1 .
-- The C compiler identification is Clang 6.0.0
-- The CXX compiler identification is Clang 6.0.0
-- Check for working C compiler: /usr/bin/clang
-- Check for working C compiler: /usr/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/clang++
-- Check for working CXX compiler: /usr/bin/clang++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    GEANT4_BUILD_MULTITHREADED

Does anyone know why the compiler is ignoring the GEANT4_BUILD_MULTITHREADED=ON command?

matt

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Warning: Re: Why Multithreaded compiler not working   (Andrea Dotti - 04 Feb, 2015)
(_ Question: Re: Why Multithreaded compiler not working   (matthew - 05 Feb, 2015)
(_ Question: Re: Why Multithreaded compiler not working   (Andrea Dotti - 05 Feb, 2015)
(_ None: Re: Why Multithreaded compiler not working   (matthew - 05 Feb, 2015)
 Add Message Add Message
to: "Why Multithreaded compiler not working"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews