Message: Memory problem in GPS Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Memory problem in GPS 

Forum: Multithreading
Date: 18 Feb, 2014
From: Andrew Green <Andrew Green>

Hello,

I've been lucky enough to have time to get Geant4 up and running on an Intel XeonPhi card and for the most part the multithreading works perfectly, without any hitches.

However, when I tried to run a mock proton therapy plan things started to go wrong. The plan involves setting up ~560 GPS sources of different energy, location and direction to imitate a scanned beam proton therapy treatment. When I do this, and then launch the maximum 244 threads, the card quickly runs out of memory (it has 16GB installed).

I should point out that the exact same code, running with only a few GPS sources runs fine, and doesn't consume too much memory.

Is anyone else using the GPS in a similar way to this? Has anyone seen similar problems, or even better has anyone solved a similar problem?

Thanks, Andrew

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Memory problem in GPS   (Andrea Dotti - 18 Feb, 2014)
 Add Message Add Message
to: "Memory problem in GPS"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews