Message: Error in building MPI version Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Error in building MPI version 

Forum: Multithreading
Date: Mar 18, 10:34
From: Sanchit Sharma <Sanchit Sharma>

Hello,

As per the manual I am trying to build the MPI libraries. However, I am getting an error during 'make' command saying:

"‘MPI’ does not name a type; did you mean ‘M_PI’?
   const MPI::Intracomm* GetComm() const { return &COMM_G4COMMAND_; }"

I have attached the screenshot below. I'd be grateful of anyhelp in this regard.

Thanks,

Sanchit Sharma

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2019/03/18/10.32-86745-error.png

 Add Message Add Message
to: "Error in building MPI version"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews