Message: Re: Strange Segmentation fault Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Strange Segmentation fault  

Forum: Multithreading
Re: Question Strange Segmentation fault (Volodymyr Rodin)
Re: None Re: Strange Segmentation fault (Makoto Asai)
Re: None Re: Strange Segmentation fault (Volodymyr Rodin)
Re: None Re: Strange Segmentation fault (Makoto Asai)
Re: None Re: Strange Segmentation fault (Volodymyr Rodin)
Date: Nov 16, 02:39
From: Volodymyr Rodin <Volodymyr Rodin>

Hi Makoto,

I have found a reason. That line in the output

 G4VIS > G4VisManager: Using G4TrajectoryDrawByCharge as fallback trajectory 
 model. 

This doesn't work for me at the number of particles <500. After adding the following line to vis.mac, the problem has disappeared.

 /vis/modeling/trajectories/create/drawByCharge

 G4WT0 > ### Run 0 starts on worker thread 0.
 G4WT1 > ### Run 0 starts on worker thread 1.
 G4WT0 > Thread-local run terminated.
 G4WT0 > Run Summary
 G4WT0 >   Number of events processed : 2
 G4WT1 > Thread-local run terminated.
 G4WT1 > Run Summary
 G4WT1 >   Number of events processed : 3
 G4WT1 >   User=0s Real=0s Sys=0s
 G4WT0 >   User=0s Real=0s Sys=0s
 Run terminated.
 Run Summary
 Number of events processed : 5
 User=0.01s Real=0.02s Sys=0.01s

Best regards,

Volodymyr

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Strange Segmentation fault   (John Allison - Nov 19, 05:56)
 Add Message Add Message
to: "Re: Strange Segmentation fault "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews