Message: Re: Request for a new forum fails Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Request for a new forum fails 

Forum: Hypernews Feedback/Problems
Re: Question Request for a new forum fails (Tomasz Wlodek)
Date: 09 Dec, 2005
From: Peter Elmer <Peter Elmer>

  Hi Tomasz,

  Looking very quickly at the things below, it isn't obvious to me what
the problem might be. Many issues are often related to permissions (e.g.
the web server runs as "apache", sometimes people install things as root
or as a dedicated "hypernews" user, the email gateway stuff is executed
by postfix, etc.)

  BTW, note that the "request new forum" page doesn't do anything other than
send a mail to the admin summarizing the information. The actual creation
of the forum is then done by the administrator of the system by hand
using the "create-forum.pl" script. (Which still has some hard-coded
comments about SLAC which we need to clean out.)

  Ah, another possibility is that the "no such file" comes from trying
to find sendmail to send this mail. IIRC, this is in the hnrc. You 
might verify that the path is correct, etc.

  [Further responses from me will be delayed on tomorrow as I'm taking
a plane in about 1.5 hours... ;-)]

                                   Pete

On Fri, Dec 09, 2005 at 09:27:26AM -0800, Tomasz Wlodek wrote:
> Hi,
> 
> I am installing HyperNews. I can register new users, now I try to create
> new forum. I click "request new forum" and I get an error:
> 
> <message begins:> Error using HyperNews at griddev04.usatlas.bnl.gov If
> you need help, please contact the administrator of HyperNews at
> griddev04.usatlas.bnl.gov: (email skipped for spammers) . Please include
> the following information.
> 
> Error evaluating: &printReqForm() No such file or directory <message
> ends>
> 
> This is followd by a dump (included below).
> 
> I know, something is wrong with my setup, but can anyone point me to
> what exactly?
> 
> Tomasz Wlodek
> 
> URL: http://griddev04.usatlas.bnl.gov/HyperNews/request-forum.pl Request
> URL: /HyperNews/request-forum.pl HTTP User Agent: Mozilla/5.0 (X11; U;
> SunOS sun4u; en-US; rv:1.6) Gecko/20040126 Remote User: tw
> (Authenticated by cookie) Server Software: Apache/2.0.46 (Red Hat)
> Server OS: Linux griddev04.usatlas.bnl.gov 2.4.21-37.ELsmp #1 SMP Wed
> Sep 7 13:28:55 EDT 2005 i686 i686 i386 GNU/Linux Server User:Group:
> apache:apache Server Administrator: root@localhost Perl Version: 5.008
> HyperNews Version: 1.11-slac-30 HyperNews Administrator: ... (skipped)
> ...
> 
> Traceback:
> 
> Calling: main::HNError In File: .scripts/hn-lib.pl At Line: 282
> 
> Calling: main::feval In File:
> /var/www/cgi-bin/HyperNews/request-forum.pl At Line: 47
> 
> ENV: 'DOCUMENT_ROOT' = '/var/www/html' 'GATEWAY_INTERFACE' = 'CGI/1.1'
> 'HTTP_ACCEPT' =
> 'text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1'
> 'HTTP_ACCEPT_CHARSET' = 'ISO-8859-1,utf-8;q=0.7,*;q=0.7'
> 'HTTP_ACCEPT_ENCODING' = 'gzip,deflate' 'HTTP_ACCEPT_LANGUAGE' =
> 'en-us,en;q=0.5' 'HTTP_CONNECTION' = 'keep-alive' 'HTTP_COOKIE' =
> 'HN_USER_PASS=tw:HNNq9YKVl9FZ.' 'HTTP_HOST' =
> 'griddev04.usatlas.bnl.gov' 'HTTP_KEEP_ALIVE' = '300' 'HTTP_REFERER' = '
> http://griddev04.usatlas.bnl.gov/HyperNews/SECURED/change-member.pl '
> 'HTTP_USER_AGENT' = 'Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6)
> Gecko/20040126' 'ORACLE_HOME' = '' 'ORACLE_SID' = '' 'PATH' =
> '/bin:/usr/bin' 'QUERY_STRING' = '' 'REMOTE_ADDR' = '130.199.48.38'
> 'REMOTE_PORT' = '40735' 'REQUEST_METHOD' = 'GET' 'REQUEST_URI' =
> '/HyperNews/request-forum.pl' 'SCRIPT_FILENAME' =
> '/var/www/cgi-bin/HyperNews/request-forum.pl' 'SCRIPT_NAME' =
> '/HyperNews/request-forum.pl' 'SERVER_ADDR' = '130.199.185.31'
> 'SERVER_ADMIN' = ' root@localhost ' 'SERVER_NAME' =
> 'griddev04.usatlas.bnl.gov' 'SERVER_PORT' = '80' 'SERVER_PROTOCOL' =
> 'HTTP/1.1' 'SERVER_SIGNATURE' = ' Apache/2.0.46 (Red Hat) Server at
> griddev04.usatlas.bnl.gov Port 80 ' 'SERVER_SOFTWARE' = 'Apache/2.0.46
> (Red Hat)' 'UNIQUE_ID' = ' jNZFDoLHuR8AAHYuM@IAAAAG '
> 
> -------------------------------------------------------------
> Visit this SLAC message (to reply or unsubscribe) at: 
> http://hypernews.slac.stanford.edu/HyperNews/hypernews/get/HNFeedBack/5.html



-------------------------------------------------------------------------
Peter Elmer     E-mail: Peter.Elmer@cern.ch      Phone: +41 (22) 767-4644
Address: CERN Division PPE, Bat. 32 2C-14, CH-1211 Geneva 23, Switzerland
-------------------------------------------------------------------------

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Hypernews icons are missing   (Tomasz Wlodek - 13 Dec, 2005)
1 None: Re: Hypernews icons are missing   (Terry Hung - 13 Dec, 2005)
1 None: How to create forums?   (Tomasz Wlodek - 15 May, 2006)
... 3 Message(s)
2 None: Re: Hypernews icons are missing   (Terry Hung - 13 Dec, 2005)
3 None: Re: Hypernews icons are missing   (Terry Hung - 14 Dec, 2005)
1 None: Re: Hypernews icons are missing   (Tomasz Wlodek - 14 Dec, 2005)
... 9 Message(s)
2 None: problem with "recent postings" link   (Tomasz Wlodek - 14 Dec, 2005)
4 None: External authentication in Hypernews   (Tomasz Wlodek - 22 Feb, 2006)
1 None: Re: External authentication in Hypernews   (Peter Elmer - 22 Feb, 2006)
... 11 Message(s)
2 None: Re: two HN questions   (Peter Elmer - 19 Jan, 2006)
1 None: how to mass-subscribe users to HN?   (Tomasz Wlodek - 19 Jan, 2006)
1 None: Re: how to mass-subscribe users to HN?   (Peter Elmer - 19 Jan, 2006)
2 None: Can HN use Apache basic authentication to authenticate users?   (Tomasz Wlodek - 25 Jan, 2006)
... 1 Message(s)
3 None: How to interface Hypernews to Apache/kerberos?   (Tomasz Wlodek - 27 Apr, 2006)
1 None: Re: How to interface Hypernews to Apache/kerberos?   (Dmitriy Kovalskyi - 27 Apr, 2006)
4 None: How to change hypernews owner?   (Tomasz Wlodek - 30 May, 2006)
5 None: Re: We are under spammer attack, How to block e-mail gateway?   (Douglas Smith - 04 Aug, 2006)
 Add Message Add Message
to: "Re: Request for a new forum fails"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ SLAC HyperNews Home | Search | Feedback ]