Message: Re: user unable to post through email Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: user unable to post through email 

Forum: Hypernews Feedback/Problems
Re: None Re: user unable to post through email (Devin Bougie)
Re: None Re: user unable to post through email (Terry Y Hung)
Re: None Re: user unable to post through email (Devin Bougie)
Date: 02 Oct, 2007
From: Terry Y Hung <Terry Y Hung>

Hi Devin,

The directory should indeed be "hndocs/REJECTMAIL" rather than "hndocs/SPAM" in the debugging message. This is now corrected and the patch will be included in the future release.

The default of spam_keyword1 was set to nill in v1.11-slac-76. You had the previous default from earlier versions of HyperNews, and the keyword happened to match the keyword on your site (generated by CERN's spam rating script).

   Thanks for the bug report!

   -- Terry Hung (terryh@slac.stanford.edu)

On Tue, 02 Oct 2007 13:36:52 GMT, Devin Bougie wrote:

> Hi Terry,
> 
> On Oct 1, 2007, at 9:15 PM, Terry Y Hung wrote:
> > in the mail-incoming.pl log:
> >> Keywords:+CERN+SpamKiller+Note:+-52
> >
> >   in the relay-email.pl log:
> >> [relmail-83] (spamFilter)  spam_rating=-52 threshold=0 compare=0
> >> [relmail-85] (spamFilter)  spam_rating: reject spam mail and save  
> >> it to hndocs/SPAM
> 
> I'm not sure if it's worth mentioning, but it doesn't look like an  
> hndocs/SPAM directory was ever created.
> 
> >    The email was rejected because both the $spam_threshold and
> > $spam_compare are set to 0. The latter means a good message has
> > rating greater than 0. In the failed case the rating is -52, and thus
> > the message was rejected and saved into hndocs/REJECTMAIL.
> >
> >    According to the log the working emails do not have the spam rating
> > header while the failed email has "Keywords: CERN SpamKiller Note:  
> > -52", which
> > by accident has the same keyword as the default.
> >
> > Two things worth trying:
> >
> >    1. If you don't need the spam filter, please set $spam_keyword1  
> > = '' in
> >       the hnrc. Otherwise continue to the following two steps.
> 
> Yes, this fixed the problem (it was actually in spam_keyword2).  I  
> don't believe we ever modified the default spam settings in hnrc, so  
> it seems possible that others have or will run into this also.
> 
> Thank you so much for your time and help.
> 
> Sincerely,
> Devin
> 

 Add Message Add Message
to: "Re: user unable to post through email"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ SLAC HyperNews Home | Search | Feedback ]