Message: Re: Still can't get the incoming mail to post Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Still can't get the incoming mail to post 

Forum: Hypernews Feedback/Problems
Date: 03 Nov, 2006
From: Terry Y Hung <Terry Y Hung>

Hi Tom,

   Please try to install the Net::SSLeay.pm perl module. You can search it
on the internet to find its source.

   Thanks!

-- 
Terry Hung - Stanford Linear Accelerator Center
phone: 650-926-3618
e-mail: terryh@slac.stanford.edu 

> 
> On Thu, 2 Nov 2006, Terry Hung wrote:
> 
> > Hi Tom,
> >
> >> ..(snip)..
> >> [hn@hnews ~]$   cat  /var/spool/mail/hn | /var/www/cgi-bin/HyperNews/.scripts/mail-incoming.pl -f /Test
> >>
> >> This dumped an error:
> >>
> >> ----error messsage begins --------------
> >>
> >> [hnlib-1.3] cannot open
> >> /var/www/hnews/hndocs/debugLog/2006/11/02/19:07:41__368307__mail-incoming.pl
> >> Can't locate MIME/Parser.pm in @INC (@INC contains:
> >> /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5
> >> /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
> >> <snip>..
> >
> >   The above is a warning message. You don't need the Parser at this point.
> > You do need it to parse the attachment once the mail system is working.
> >
> >> Error evaluating: &MailIncomingPL()
> >> Can't locate Net/SSLeay.pm in @INC (@INC contains:
> >
> >   This is where the error lies. The Net::SSLeay.pm is a perl module that
> > allows HN to call Secure Sockets Layer (SSL) functions. I will modify setup.pl
> > to test the availability of this module during setup. Thanks for this test!
> >
> >> /var/www/cgi-bin/HyperNews /var/www/cgi-bin/HyperNews/.scripts
> >> /var/www/cgi-bin/HyperNews/.scripts/lib /var/www/cgi-bin/HyperNews
> >> /var/www/cgi-bin/HyperNews/.scripts
> >> <snip>..
> >> Does this mean anything?
> >
> >   This test showed the reason why mail-incoming.pl failed. The reason why
> > these errors did not show up in the apache's error log was because it was
> > the mail server that executed the mail-incoming script, not the apache server.
> > Overall this test is very useful.
> >
> >   Thanks!
> >
> 
> Is there anything I can do to fix this problem?
> 
> -- 
> Tomasz Wlodek                        | tel 631-344-7448
> Brookhaven Laboratory, Building 510M | fax 631-344-7616
> Upton NY 11973-5000                  |
> 

 Add Message Add Message
to: "Re: Still can't get the incoming mail to post"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ SLAC HyperNews Home | Search | Feedback ]