Message: Re: how to debug mail-incoming.pl? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: how to debug mail-incoming.pl? 

Forum: Hypernews Feedback/Problems
Date: 13 Oct, 2006
From: Terry Y Hung <Terry Y Hung>

Hi Tom,

   You can turn on the debugging in hndocs/debugOption by setting the
master switch DEBUG=1 and leave the default debug[2] and debug[3] to 1
for mail debugging.

   The log will be created in hndocs/debugLog.

   regards,
-- 
Terry Hung - Stanford Linear Accelerator Center
phone: 650-926-3618
e-mail: terryh@slac.stanford.edu 

> 
> Hi,
> 
> I ahve set up a Test forum in HN. To post to it I have to write to 
> Hypernews-Test@hnews.... The mail arrives and in the /etc/aliases I 
> forward it to account hn. Then in the account hn I do have a .procmailrc 
> file with the following directive:
> 
> :0 c
> * ^TO HyperNews-Test
> | /var/www/cgi-bin/HyperNews/.scripts/mail-incoming.pl -f /Test
> 
> Incoming mail arrives to hn machine, it is directed to hn account - but 
> then somehow /mail-incoming.pl does not post it to forum Test.
> 
> The mail-incoming.pl script works standalone:
> 
> perl -c mail-incoming.pl
> mail-incoming.pl syntax OK
> 
> also procmail works - if I replace the line
> | /var/www/cgi-bin/HyperNews/.scripts/mail-incoming.pl -f /Test
> with
> |cat >temp.file
> the incoming mail is written into temp.file
> 
> So the problem is that mail-incoming.pl does not post the incoming mail to 
> the forum Test. How can I debug it? Is there a mail-incoming.pl log 
> somewhere?
> 
> -- 
> Tomasz Wlodek                        | tel 631-344-7448
> Brookhaven Laboratory, Building 510M | fax 631-344-7616
> Upton NY 11973-5000                  |
> 

 Add Message Add Message
to: "Re: how to debug mail-incoming.pl?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ SLAC HyperNews Home | Search | Feedback ]