Message: Re: Initial run of GRAS-03-03 with geant4.9.6.p04 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Idea Re: Initial run of GRAS-03-03 with geant4.9.6.p04 

Forum: Space Applications
Re: Question Initial run of GRAS-03-03 with geant4.9.6.p04 (Richard Gillham Darnley)
Date: 04 Mar, 2015
From: Michael H. Kelsey <Michael H. Kelsey>

On Wed, 04 Mar 2015 12:05:37 GMT, Richard Gillham Darnley wrote:
> I have just installed geant4.9.6.p04 and GRAS-03-03 on my linux
> computer. I have enabled GDML options and ran example G01 to test my
> basic GDML and XercesC install. This example worked fine.
> 
> When running the configure_and_install.sh script for GRAS-03-03 I had to
> add the following cmake options so that it could find XercesC:
> 
> -DXERCESC_LIBRARY=/home/richard/xercesc/xerces-c-src_2_8_0/lib/libxerces-c.so
> -DXERCESC_INCLUDE_DIR=/home/richard/xercesc/xerces-c-src_2_8_0/include
> 
> Now when I attempt to run gras by typing 'gras' in the terminal I get
> the following message:
> 
> gras: error while loading shared libraries: libxerces-c.so.28: cannot
> open shared object file: No such file or directory

Add the XercesC library directory to your LD_LIBRARY_PATH.  This isn't done for your by G4; you have to do it yourself.
                 -- Michael Kelsey

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Initial run of GRAS-03-03 with geant4.9.6.p04   (Richard Gillham Darnley - 04 Mar, 2015)
 Add Message Add Message
to: "Re: Initial run of GRAS-03-03 with geant4.9.6.p04"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]