Message: Re: Sensitive detector doesnt work Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Sensitive detector doesnt work 

Forum: Biasing and Scoring
Re: Sad Sensitive detector doesnt work (Steinbach)
Re: None Re: Sensitive detector doesnt work (Tsukasa Aso)
Re: None Re: Sensitive detector doesnt work (Steinbach)
Re: None Re: Sensitive detector doesnt work (Tsukasa Aso)
Date: 25 Feb, 2015
From: Steinbach <Steinbach>

Thank you so much Tsukasa.

The PhysicsList is updated and I got the photons to interact with the Si now.

Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/02/25/04.43-82478-PhysicsList.cc


I have not added any standard physics list yet, since its working, I will play with it later when I have the whole system working.

But......but........in the histogram I see all the particles that I am shooting + all the secondary electrons. This will hopefully, probably will be fixed when scoring and ExpoSD is updated as you suggested. Working on it :-)

Will be back when I have something to share with you. Thanks.

/Steinbach.








On Tue, 24 Feb 2015 23:57:18 GMT, Tsukasa Aso wrote:
> Hi,
>
> There are several points you have to care about:
>
> 1) PhysicsList
> Your physics list includes only the transportation process. e.g. no physics interactions.
> I recommend to use a reference physics-list. Please check examples in Geant4 such as
> basic or extended/electromagnetic.
>
> 2) Scoring
> The histogram you are checking is for a kinetic energy spectrum of a track.
> It is not the energy deposit in the Si-plate. It is an initial kinetic energy of a track.
>
> Please check the examples in Geant4 such as basic/B4c etc.
> Basically you need to check ( or do )
> a) Define a histogram for energy deposited in RunAction
> b) Fill the histogram in EventAction by getting the energy deposited from hitscollection.
>
> 3) A comment about your ExgpsSD
> You use "hit" and "hitTotal". But in your code, the only one hit object is registered in
> the hitscollection. Therefore the "hit" and "hitTotal" is same and it causes double counting.
>
> Regards,
> T.A
>






   

 Add Message Add Message
to: "Re: Sensitive detector doesnt work"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews