Message: Re: Sensitive detector doesnt work Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Sensitive detector doesnt work 

Forum: Biasing and Scoring
Re: Sad Sensitive detector doesnt work (Steinbach)
Re: None Re: Sensitive detector doesnt work (Tsukasa Aso)
Re: None Re: Sensitive detector doesnt work (Steinbach)
Re: None Re: Sensitive detector doesnt work (Tsukasa Aso)
Date: 24 Feb, 2015
From: C Mos <C Mos>

Ok... so I run B4c with the modified physics list (aka. FTFP_BERT_HP) and this is what I noticed. When I run the executable and I exit right away, I get a core dumped.

  Total navigation history collections cleaned: 2
  ================== Deleting memory pools ===================
  Number of memory pools allocated: 3; of which, static: 0
  Dynamic pools deleted: 3 / Total memory freed: 0.0029 Mb
  ============================================================
  G4Allocator objects are deleted.
  UImanager deleted.
  StateManager deleted.
  RunManagerKernel is deleted. Good bye :)
  Segmentation fault (core dumped)
  [kurama@kurama B4c]$ 

When I run the executable and then I execute '/run/beamOn 1' and then I exit the program, it finishes normally:

  Total navigation history collections cleaned: 8
  ================== Deleting memory pools ===================
  Number of memory pools allocated: 15; of which, static: 0
  Dynamic pools deleted: 15 / Total memory freed: 0.037 Mb
  ============================================================
  G4Allocator objects are deleted.
  UImanager deleted.
  StateManager deleted.
  RunManagerKernel is deleted. Good bye :)
  [kurama@kurama B4c]$

I got the same results with Hadr01 running the following lines:

  Hadr01 vis.mac FTFP_BERT_HP   --> RunManagerKernel is deleted. Good bye :)
                                    Segmentation fault (core dumped)
  Hadr01 vis.mac FTFP_BERT      --> Normal termination!

I modified the vis.mac so to include '/run/beamOn 1' and results are the same, as I get a cored dumped with FTFP_BERT_HP physics even when calling '/run/beamOn 1'.

Last check of sanity. I run my program and yes, if I do not generate any events via '/run/beamOn' but I exit right away, I get a core dumped. However, I a generate events before exiting, I get a normal termination line:

  Idle> exit
  Graphics systems deleted.
  Visualization Manager deleting...
  Total navigation history collections cleaned: 26
  Normal termination of ./APIdrdcAppTNAV6-0 at Tue Feb 24 22:22:03 2015

I will try to use gdb. However, it is a learning curve for me using geant4 libraries. One question. With my program when I get a segmentation fault I always get extra debugging lines. However with Hadr01 and B4c I just have a "core dumped" and then exist right away. I did compile my geant 4 engine with

  -DCMAKE_BUILD_TYPE=Debug

Any ideas why this happen this way?

Cheers!

C Mos

 Add Message Add Message
to: "Re: Sensitive detector doesnt work"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews