Message: Re: Sensitive detector doesnt work Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Sensitive detector doesnt work 

Forum: Biasing and Scoring
Re: Sad Sensitive detector doesnt work (Steinbach)
Re: None Re: Sensitive detector doesnt work (Tsukasa Aso)
Re: None Re: Sensitive detector doesnt work (Steinbach)
Date: 24 Feb, 2015
From: Tsukasa Aso <Tsukasa Aso>

Hi,

  There are several points you have to care about:

1) PhysicsList
    Your physics list includes only the transportation process. e.g. no physics interactions.
    I recommend to use a reference physics-list. Please check examples in Geant4 such as
   basic  or extended/electromagnetic.

2) Scoring
    The histogram you are checking is for a kinetic energy spectrum of a track.
    It is not the energy deposit in the Si-plate. It is an initial kinetic energy of a track.

    Please check the examples in Geant4 such as basic/B4c etc. 
      Basically you need to check ( or do )
       a)  Define a histogram for energy deposited  in RunAction
       b)  Fill the histogram in EventAction by getting the energy deposited from hitscollection.
       
3) A comment about your ExgpsSD
    You use "hit" and "hitTotal". But in your code, the only one hit object  is registered in
the hitscollection. Therefore the "hit" and "hitTotal" is same and it causes double counting.

Regards,
T.A

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Sensitive detector doesnt work   (C Mos - 24 Feb, 2015)
2 None: Re: Sensitive detector doesnt work   (C Mos - 24 Feb, 2015)
3 None: Re: Sensitive detector doesnt work   (Steinbach - 25 Feb, 2015)
4 None: Re: Sensitive detector doesnt work   (Steinbach - 03 Mar, 2015)
1 None: Re: Sensitive detector doesnt work   (Tsukasa Aso - 03 Mar, 2015)
 Add Message Add Message
to: "Re: Sensitive detector doesnt work"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews